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Tutorial 02 includes:

• One .ntw (MorphoDig project) �le

• One .vtk surface �le representing a right inner ear of Galago sp

• One .pos (position) �le

• One .ori (orientation helper labels) �le

• One .ver (landmark coordinates) �le

• One .stv (curve nodes and curve handles) �le

• The present .pdf document

2.1 About the specimen

The surface �le enclosed in this tutorial represent three-dimensional reconstruction of the right
inner ear of a Galago sp obtained by computerized microtomography at the MRI µ CT platform
housed at the ISEM.
Before using this tutorial, please download and read MorphoDig User Guide.

2.2 A brief overview of enclosed �les

Download and unzip the �les associated to this tutorial. Open MorphoDig.
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2.2.1 Galago inner ear surface and position �les

You may open the enclosed .vtk surface �le (File -> Surface -> Open Surface, then select
"Galgo_sp_right_ear.vtk", or drag and drop this �le in the 3D main window). When opened
this way, the corresponding opened surface object is drawn grey, which indicates that this sur-
face is selected. You may interact with selected objects in di�erent ways (see MorphoDig user
guide for further explanations).

By default ( ), the camera rotates around the center of mass of all opened objects. This
behavior is useful when the center of mass of an object (or of several ones) is far from the
origin of the coordinate system. But by pressing the camera button ( -> ), the camera will
revolve around the center of the coordinate system (x=0, y=0, z=0). The display grid is drawn
using di�erent colors depending on the camera rotation center (see Fig. 2.1 p.4).

As a general rule, when opening a new surface, it is strongly advised to change its position
in order that it matches the 6 prede�ned camera positions :

view object from right side

view object from left side

view object from front side (default camera position)

view object from back side

view object from above

view object from below

In "object interaction mode( )", selected objects can be translated and rotated using the

left and middle mouse buttons (in landmark and camera selection modes, you also need to
maintain �CTRL" button pressed while dragging the left mouse button to achieve rotation and
translation of selected objects). Alternatively, you may also use the "yellow sliders" located on
the right side of the 3D main window to accomplish rotation and translation of selected objects.
Rotation is achieved around the global center of mass of all currently selected objects.

A convenient way to orient a right inner ear in a biologically relevant way is done as follows
(see Fig. 2.2 p.5):

1) place camera to view object from the front side ( )
2) place the lateral semi-circular canal in the horizontal plane (x-y plane)

3) place camera to view object from above ( )
4) rotate the inner around the z axis ("rz" yellow slider) until the later semicircular points
towards the top left-hand part of the screen, and the cochlea points towards the bottom right-
hand of the screen.

That way, when viewing the inner ear from the front side ( ), it is approximately oriented in
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Figure 2.1: Grid display color. Left: when the camera revolves around the center of
mass of all opened objects, the grid has a blue outline. Right: when the camera revolves
around the origin of the coordinate system (x=0, y=0, z=0), the grid outline is displayed
in orange.

the same way as it would be within the cranium viewed from the front side as well.

The present tutorial contains a .pos (position) �le, which you may open in order to place
correctly the right ear of the Galago (File -> Position-> Open Position for selected surfaces,
then choose "Galago_sp_right_ear.pos", see Fig. 2.2 p.5). As we plan to place curve node
landmarks and curve handle landmarks inside the cochlea and the semicircular canals, please
select the right inner ear surface (CTRL+A, or drag right mouse button to draw a selection rect-
angle) and change its transparency (Edit Selected Surface->rendering modi�cations->Change
transparency -> then give a value smaller than 100).
All opened surfaces can be unselected by pressing "CTRL +D", or selected by pressing "CTRL
+A". All selected objects can be deleted by pressing "Del".

2.2.2 Galago inner ear project �le

The present tutorial contains a project .ntw �le, which may be useful to directly open the right
inner ear in a convenient position, to make it transparent and to give it a color. First, delete all
currently opened objects (press "CTRL+A", then press "Del"). Then open the enclosed .ntw
�le (File -> Open Project, then select "Galago_sp_right_ear.ntw"). Once loaded, the right
inner ear surface is opened, is given the position enclosed in the "Galago_sp_right_ear.pos"
�le, a color and a transparency. Note that the newly opened surface is unselected.
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Figure 2.2: A convenient way to orientate right inner ears. Left: when viewed from the
front side, the lateral canal is placed horizontally. Right: when viewed from above, the
cochlea points towards the bottom right-hand of the screen, and the lateral canal towards
the top left-hand of the screen.

2.2.3 Galago inner ear curve �le

3D Curves are constructed in MorphoDig using 2 series of landmarks : a series of "curve node"

landmarks ( ), and a series of "curve handle" landmarks ( ). The numbers of curve nodes
and curve handles should be equal. The Galago_sp_right_ear.stv contains the 3D coordinate
of a series of 32 "curve node" and 32 "curve handle" landmarks. You can load it (File->Curves-
>Load MorphoDig Landmark/Curve �le(.STV), or drag and drop this �le directly in the 3D
main window).

You may consider to change the way landmarks and curve handles are rendered in the
"Landmark and �ag options" window (Edit->Edit landmark and �ag rendering options ). In
this tutorial, you may render landmarks as spheres and let MorphoDig adjust automatically
landmark rendering size with an adjustment scale factor of 0.6.

2.2.4 Galago inner ear .ori �le

The present tutorial contains a .ori �le, which contains orientation labels for the coordinate
system orientation helper. You can load this �le the enclosed .ori �le ("File->Orientation helper
labels -> Open Orientation labels", then select "Galago_sp_right_ear.ori"). Once loaded, the
system coordinate orientation helper will show the following labels :
+z axis : superior
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-z axis : inferior
+y axis : medial
-y axis : lateral
+x axis : proximal
-x axis : distal
You may set your own orientation axis labels with the �Edit orientation labels� window (Edit->
Edit orientation labels)

2.3 Curve digitization with MorphoDig

When digitizing curve node and curve handle landmarks, I recommend to press " " to acti-
vate the "Landmark mode". When active, only landmarks can be selected/unselected via right
mouse button drag/click.

As stated earlier, two series of landmarks involved into the construction of 3D curves can

be set with MorphoDig: "curve node" and "curve handle" landmarks. Press " " to activate

curve node landmark setting mode, � � to activate curve handle landmark setting mode mode.

Landmarks can be set on surfaces by pressing "L" + left mouse click. If a single landmark
is selected, its position can be moved on another part of the surface by pressing "L" + right
mouse click (nothing happens if no landmark is selected or if more than one landmark are
selected). Also, you may need to move landmarks away from the object's surface (for instance
when you want to place a landmark at the centere of a semicircular canal): once selected, a
landmark position can be moved by using the usual mouse (CTRL + middle click + mouse
drag) and GUI controls.

You may sometimes need to reorder landmark objects. Selected curve node/handle land-
marks can be reordered using the following buttons. Clicking on will increase (= move down
in list, if possible) the landmark number of all selected landmarks. Clicking on will decrease
(=move up in list, if possible) the landmark number of all selected landmarks.

2.3.1 Digitization strategy

To digitize curves on an inner ear, I recommend to use the following 3 steps strategy:

1) Digitize a series of "curve node" landmarks, and de�ne curve starting points

As curves pass through curve node landmarks, these curve nodes will endorse the role of the
"skeleton" of all curve segments. In the present tutorial, a series of 32 "curve node" landmarks
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Figure 2.3: Curve digitization strategy with MorphoDig. A: digitization of curve node
landmarks. B: Nodes 10, 16 and 25 are now starting nodes (dark green). C: Nodes nodes
15, 24 and 32 are connected to their preceding starting node to close the three semicircular
canals. D: Curve node coordinates were saved as a .ver �le, and are loaded in a second step
as handle landmarks (violet). E: Curve handles were displaced automatically. F: several
curve nodes and curve handles were displaced manually (last and most time consuming
step)
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was set inside the cochlea, the lateral semicircular canal, on the anterior and posterior semi-
circular canals (Fig. 2.3-A p.7). You may load the enclosed .ver �le (File->Curves->Open
Curve Node Landmarks-> Galago_sp_right_ear.ver).

Then select landmarks 10, 16 and 25, and de�ne them as curve starting points (Landmarks-
>Selected curve node and curve handle landmarks-> Normal nodes (red): de�ne as starting
nodes (dark green)). The consequence of this action is that the series of 32 landmarks will
contain four curves : one de�ning the cochlea, and one for each of the 3 semi-circular canals
(Fig. 2.3-B p.7).

As an option, you may select curve nodes 15, 24 and 32 and connect them to their preceding
starting nodes (Landmarks->Selected curve node and curve handle landmarks-> Normal nodes
(red): connect to preceding starting nodes (cyan)). The consequence of this action is that the
curves representing the 3 semi-circular canals will be closed (Fig. 2.3-C p.7).
Save the current series of landmarks (File->Curves->Save Curve Node Landmarks).

2) Load curve handles and modify their position semi-automatically

- Load curve handles (File->Curve->Open Curve Handle Landmarks-> then select the �le you
just created in the preceding step, here choose the "Galago_sp_right_ear.ver" �le, Fig. 2.3-D
p.7).
- Select all the curve handles (the easiest way to achieve this is to press "CTRL +A", to select
all currently opened objects).
- Move curve handles semi-automatically (Landmarks->Selected curve node and curve handle
landmarks-> Move curve handles semi-automatically). Choose a value of 25%, press "Ok" (Fig.
2.3-E p.7), and then unselect all objects (CTRL+D).

3) Modify curve handles and normal landmarks manually

The last step (and probably the hardest one) is to move manually the curve nodes and curve
handles in order to make the curves follow the geometry of the studied structures (Fig. 2.3-F
p.7).

2.3.2 Saving and exporting curves

To save all digitized curves, go in "File->Curves" and either save curve nodes and curve handles
inside a .STV (recommended) or .CUR �le.
To export all digitized curve segments into series of equidistant semi-landmarks (these latter
ones will be used in geometric morphometric analyses), go in "File->Curves->Export curves
segments as landmark �le" (See Fig. 2.4 p.9).
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Figure 2.4: Exporting curves. A: curve digitization involving with 32 curve node and
32 curve handle landmarks. B: each curve segment was exported as 20 equidistant semi-
landmarks inside a .ver �le. These equidistant semi-landmarks are those used in geometric
morphometric analyses.

2.3.3 Saving the project

Saving a "project" makes it possible to save all opened selected objects and their properties
(surface of the inner ear, its transparency, color and position, curve nodes, curve handles)
altogether instead of one by one. To save all opened objects, do the following sequence of
actions:
1) press "CTRL + A" to select all objects
2) click on "File->Project->Save Project" or on the button "save project" ( ) inside the main
window.
3) choose the desired options in the "Save Project" window (see Fig. 2.5 p.10 and the User
Guide for further details regarding the available options)

The advantage of working with projects is that all involved objects and their properties
(surfaces, landmarks, positions etc.) can be reloaded later all at once (and not 1 by 1).
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